WP 2.5 und das Plugin WP Table 1.52

WP-table ist sehr beliebt. In der offiziellen Liste steht drin, dass es mit WP 2.5 nicht kompatibel ist. Dies kann ich so nicht bestätigen. WP-table hat allerdings so hie und da Konflikte mit anderen Plugins in WP 2.5 und WP 2.6.

Mit WP-table kann man Datentabellen in WordPress leicht erstellen und verwalten.

Achtung für alle, die Probleme mit WP Table haben gibt es einen „FIX“:

Die Datei des Plugins mit einem Texteditor öffnen. Nach der Zeile 344 suchen oder nach folgender Zeile:

require_once(WPTABLE_ABSPATH.'js/buttonsnap.php');

Vor dieser Zeile folgendes einfügen:

if( !class_exists('buttonsnap') )

das ganze sollte dann so aussehen:

// ButtonSnap needs to be loaded outside the class in order to work right
if( !class_exists('buttonsnap') )
require_once(WPTABLE_ABSPATH.'js/buttonsnap.php');

Der Dank geht an mosey. :-)

Untenstehende Hilfe ist somit überholt ;)

Da hilft nur der langwierige Weg:

Ein weiteres Plugin aktivieren,wieder WP-table testen.

Das Plugin deaktivieren ein nächstes dazuschalten usw.

WP Table wird derzeit nicht erneuert, weil der Pluginautor keine Zeit hat – mag wer anderer?

Artikelhistorie:

Erstveröffentlichung am 7.04.08

lg
5

5 Beiträge zu “WP 2.5 und das Plugin WP Table 1.52

  1. Kommentar Autor
    Uwe
    Kommentar

    Hallo zusammen,

    ich benutze auch „WP Table 1.52“ und habe eine Menge an Tabellen für Schonzeiten der einzelnen Bundesländer. Dazu auch noch zig andere Plugins und habe keine Fehler feststellen können. Gibt es da schon Info´s welche Plugins Probleme verursachen könnten ?

    lg
    Uwe

  2. Kommentar Autor
    Fred
    Kommentar

    Hallo Moniik.

    I’m trying use the wp2.6 in my blog but receive many problems.
    Really, some plugins still not run perfect in wp2.6.

    Bis bald!

  3. Kommentar Autor
    Mosey
    Kommentar

    Thanks for the mention on your site! :) However, credit must go to Michael Bester.

  4. Kommentar Autor
    Monika
    Kommentar

    ho Mosey
    Michael is in my *privat* plugin list at this page, ;) but your „workaround“ is so helpfully for so many WP user

    thanks a lot
    Monika

  5. Kommentar Autor
    Karl
    Kommentar

    wp_table 1.52 – ich bekomme das mit dem bugfix unter wp 2.7b3 zum laufen, beim Tabellenanlegen kommt dieser Fehler: Database error. Could not perfom all action.

    hat da jemand einen Tipp? Zu dem Plugin scheits ja keine Alternative zu geben.

    Karl